Site loading issues
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 13:39 EST
Update
We are continuing to investigate this issue.
Posted Jan 09, 2020 - 13:32 EST
Investigating
Some users may be experiencing slowness or issues loading our sites. We’re investigating, and appreciate your patience!
Posted Jan 09, 2020 - 13:31 EST
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.