Site login issues
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 10:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2020 - 10:20 EDT
Identified
We’re aware that users are experiencing issues logging into our sites. We’re working on it, and expect it to be up and running within the next few hours. We appreciate your patience!
Posted Apr 21, 2020 - 08:08 EDT
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, BrainPOP Français, iOS Apps, and Android Apps.