Content and Activity Loading Degradation

Incident Report for BrainPOP

Resolved

BrainPOP is back online and operating normally. The issue affecting site availability has been resolved. We are continuing to monitor and will follow up with a full incident report.

We apologize for the disruption.
Posted May 12, 2026 - 11:04 EDT

Update

We are continuing to investigate this issue. BrainPOP is currently unavailable. Our team is actively working on a resolution and we will provide another update shortly. We apologize for the inconvenience.
Posted May 12, 2026 - 10:50 EDT

Investigating

We are currently investigating an issue that may be affecting some users. During this time, you may experience:

- Errors or timeouts when loading content
- Activity or progress not saving
- Pages that are slow to load or unresponsive

We are actively working to resolve this and will provide an update shortly. Thank you for your patience.
Posted May 12, 2026 - 10:12 EDT
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Science, BrainPOP Español, BrainPOP Français, and iOS Apps.