Intermittent Site Performance Issues
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 20, 2017 - 16:19 EST
Monitoring
Due to increased traffic to our sites, we're in the process of migrating our servers to a faster and more robust platform. In the meantime, some users may experience short periods of slowness or other site issues, generally during our peak traffic time - 1:00 - 2:30 pm EST - over the next few weeks.
Posted almost 2 years ago. Sep 28, 2017 - 14:05 EDT