Site loading issues
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 05, 2018 - 12:09 EDT
Update
We are continuing to investigate this issue.
Posted 7 months ago. Sep 05, 2018 - 11:52 EDT
Investigating
Some users are experiencing slowness or other issues loading our sites. We're working on it, and appreciate your patience!
Posted 7 months ago. Sep 05, 2018 - 11:00 EDT
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.