We have identified the root cause of this issue. A fix has been implemented and the site is operating normally. We are continuing to monitor to confirm full stability.
We will follow up with a full incident report. We apologize for the disruption.
Posted May 12, 2026 - 14:14 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2026 - 14:11 EDT
Investigating
We are investigating an issue causing the site to be slow and intermittently unavailable. This issue recurred following a brief period of recovery earlier today. Our team is actively working toward a full resolution.
We will provide updates as the situation develops. We apologize for the inconvenience.
Posted May 12, 2026 - 11:56 EDT
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Science, BrainPOP Español, BrainPOP Français, and iOS Apps.