Database related issues
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted about 1 year ago. Jan 05, 2018 - 12:05 EST
Investigating
Some users may be experiencing issues with login and intermittent page loading.
Posted about 1 year ago. Jan 05, 2018 - 12:01 EST