Error playing movies for some users
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted 11 months ago. Apr 18, 2018 - 11:27 EDT
Investigating
Some users in certain regions may be experiencing errors playing our movies. We're looking into this issue with our CDN provider.
Posted 11 months ago. Apr 18, 2018 - 09:39 EDT