Site slowness and 502 errors
Incident Report for BrainPOP
Resolved
Site performance should be restored for users in the NY Region.
Posted Oct 07, 2019 - 16:54 EDT
Identified
Our CDN provider is experiencing localized issues in the NY Region. Users in this region may be experiencing slowness on BrainPOP Jr., BrainPOP ELL, and our teacher and student dashboards. We're actively monitoring the issue and will update when it has been resolved.
Posted Oct 07, 2019 - 14:43 EDT
Investigating
Some users may be experiencing site slowness or other loading issues with BrainPOP Jr. or BrainPOP ELL. We're aware and working on it! Thank you for your patience!
Posted Oct 07, 2019 - 13:41 EDT
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.