Site slowness and 504 errors
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 30, 2018 - 19:10 EST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Nov 29, 2018 - 10:26 EST
Investigating
Some users may be experiencing site slowness or other loading issues with our sites. We're aware and working on it! Thank you for your patience!
Posted 6 months ago. Nov 28, 2018 - 10:30 EST
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.