Site slowness or 504 errors
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted 4 months ago. Nov 27, 2018 - 12:23 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Nov 27, 2018 - 11:37 EST
Investigating
Some users may be experiencing site slowness or other loading issues. We're aware and working on it!
Posted 4 months ago. Nov 27, 2018 - 09:42 EST
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.