Site Slowness
Incident Report for BrainPOP
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 11:01 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2022 - 10:35 EST
Identified
Some users may be experiencing site slowness or other loading issues with our sites. We're aware and working on it! Thank you for your patience!
Posted Nov 28, 2022 - 09:28 EST
This incident affected: BrainPOP, BrainPOP Jr., BrainPOP ELL, BrainPOP Español, and BrainPOP Français.